Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 26, 2026 - 00:00 EST
Scheduled
DFT Wireless services will perform routine firmware and software upgrades to customer routers. During this time, customers with fixed DFT Wireless services may experience a brief interruption while services are reloaded.
Please do not make any changes to your equipment or endpoints. If your service does not return after the maintenance window, please power cycle your equipment or contact DFT Repair & Support at 716-673-3011.
Posted Feb 23, 2026 - 14:07 EST
This scheduled maintenance affected: DFT Wireless Services.