Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 29, 2025 - 01:00 EDT
Scheduled
Our Network Engineering team will be conducting emergency maintenance on core network infrastructure during the scheduled maintenance window. During this time, all services will be transitioned to standby and redundant systems to minimize any potential disruption.
While no customer impact is anticipated, we strongly recommend that customers with critical internet needs ensure their backup procedures are active and tested.
Please do not make any changes to your equipment or endpoints.
If you have any questions, please contact DFT Support & Repair at 716-673-3031
Posted May 27, 2025 - 09:58 EDT
This scheduled maintenance affected: Netsync Internet Services.