All services have been restored as of 10:45 am. Network Operations will continue to monitor for any further abnormalities.
If you experience any difficulty when calling, please contact DFT Repair & Support at 716-673-3031.
Please be sure to include
Originating Number Terminating Number Date/Time of Call Result (Busy, Dead Air, etc.)
Posted Jan 07, 2026 - 11:14 EST
Update
Technicians have identified a hardware fault and are currently working on the repair.
ETR is now 11am EST
Posted Jan 07, 2026 - 08:56 EST
Identified
Network Operations has identified an issue with local calling from DFT to Windstream Jamestown customers. The call completion issues affect only local calls to the Jamestown, NY area for customers with Windstream telephone service. All other services are working as expected.
Technicians are currently working on the issue. No estimated time of repair is available at this time.
If you have any questions please contact DFT Repair and Support at 716-673-3011
Posted Jan 07, 2026 - 08:18 EST
This incident affected: DFT Hosted Voice over IP (VoIP), D&F Telephone Services, and Cassadaga Telephone Services.