Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 02, 2025 - 00:00 EDT
Scheduled
Customers with Fixed DFT Wireless Service may experience intermittent interruptions during infrastructure software upgrades.
Areas impacted - Wright Rd, Dunkirk, Dybkas Road Ventura Circle and other surrounding areas
Customers should not make any changes to their equipment, routers, or endpoints during the maintenance window. If services do not return after the maintenance window, then customers will need to power cycle their WiFi Router and CPE (Outdoor Radio).
If you need any assistance or have any questions, please contact DFT Support and Repair at 716-673-3011
Posted Sep 29, 2025 - 16:17 EDT
This scheduled maintenance affected: DFT Wireless Services.