Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2024 - 01:00 EDT
Scheduled
DFT Wireless will be performing maintenance on our Wireless Services within the following areas
- Farrington Hollow, Dybkas Road, North Hill, Dake Hill, Foster Hill and Surrounding Areas - Dunkirk High Rise & Vicinity - Ventura Circle Areas (Fredonia)
During this maintenance, customers may experience brief interruptions with their service. Customers should not make any changes to their equipment or endpoints
Posted Mar 18, 2024 - 14:59 EDT
This scheduled maintenance affected: DFT Wireless Services.