Internet Impairment

Incident Report for DFT Communications Network Status

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 16:31 EDT

Monitoring

All Netsync services have been fully restored. No immediate fiber damage was detected, and Network Operations considers this to be an isolated incident with the backbone carrier.

Engineers will monitor the services for the next 30 minutes. If you still experience service issues, please contact DFT Support & Repair at 716-673-3011. Thank you for your patience.
Posted Mar 31, 2026 - 16:00 EDT

Investigating

Customers may have experienced a brief interruption of the Internet Services while redundancies were activated. Based on initial findings, due to inclement weather in the area, there may be damage to outdoor fiber-optic cable between Netsync and one of our transit backbone providers.

Network Technicians and Engineers are currently investigating. Please do not make any changes to your equipment, routers, endpoints, or devices. If you need further assistance, please contact DFT Repair & Support at 716-673-3011.

Updates will be provided when available.
Posted Mar 31, 2026 - 15:29 EDT
This incident affected: Netsync Internet Services.