Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 27, 2025 - 09:00 EDT
Scheduled
Customers with DFT Wireless Service from Dybkas Road may experience brief interruptions of service while maintenance is performed. Areas include
Dybkas Road, North Hill Foster Hill Dake Hill Otto, and the surrounding areas
Customers should not make any changes to their equipment, routers, and endpoints during the maintenance window. If services do not return after the maintenance window, customers will need to power cycle their WiFi Router and CPE (Outdoor Radio).
Please contact DFT Repair & Support at 716-673-3011 if you have any questions or need assistance.
Posted Aug 26, 2025 - 12:02 EDT
This scheduled maintenance affected: DFT Wireless Services.