Hosted VoIP Calling Impairment

Incident Report for DFT Communications Network Status

Resolved

Engineers have identified the root cause and have corrected the issue.

If you are still experiencing any Hosted Voice impairment, please contact DFT Support & Repair at 716-673-3031
Posted Jun 23, 2025 - 11:32 EDT

Identified

Services have been restored. Network Engineers are investigating for root cause analysis.

If you are still having service impairment with your Hosted Voice Service, please contact DFT Repair at 716-673-3031
Posted Jun 23, 2025 - 10:23 EDT

Investigating

Customers with DFT Hosted Voice Service may be experiencing an issue with their service. Network Engineers are currently investigating the issue.

Please do not make any changes to your endpoints or equipment.
Posted Jun 23, 2025 - 10:18 EDT
This incident affected: DFT Hosted Voice over IP (VoIP).