Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 22, 2026 - 02:00 EST
Scheduled
DFT will be performing routine routing maintenance on Backbone Routers during the hours listed. Although no service interruptions are expected, inherent risks are always present during routine maintenance.
Customers with Internet requirements are advised to have backup connections or business continuity procedures ready if service becomes unavailable. Customers should not make any changes to their equipment, endpoints, routers, or other CPE.
Please contact DFT Repair & Support at 716-673-3031 if you have any questions or concerns
Posted Jan 20, 2026 - 12:19 EST
This scheduled maintenance affected: Netsync Internet Services, DFT Residential & Business Fiber Service, DFT Wireless Services, and DFT xDSL Residential & Business Internet.