Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 21, 2024 - 01:00 EST
Scheduled
Netsync Internet Services will be upgrading Internet Backbone Routers and Equipment during the hours specified. While this work is in progress, there may be brief interruptions to Internet Service as we switch route tables to our backup systems.
We don't anticipate significant service disruptions, but customers should have downtime procedures ready in case of any unforeseen issues.
If you have any questions or concerns, please reach out to DFT Repair & Support at 716-673-3011.
Posted Nov 18, 2024 - 07:56 EST
This scheduled maintenance affected: Netsync Internet Services, DFT Residential & Business Fiber Service, DFT Wireless Services, and DFT xDSL Residential & Business Internet.