Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 09, 2025 - 00:00 EDT
Scheduled
Netsync’s Backbone Transport providers will be performing routine network maintenance during the abovementioned hours. There may be a brief service interruption while redundancy is activated.
Please do not make any changes to your equipment or endpoints.
If you have any questions please contact DFT Repair & Support at 716-673-3031
Posted May 19, 2025 - 15:52 EDT
This scheduled maintenance affected: Netsync Internet Services.