Network Engineers have restored all Voice Services and are monitoring for any further issues.
No further changes are required. If you are experiencing any service impairment, please contact DFT Support & Repair at 716-673-3011.
Posted Sep 05, 2026 - 21:45 EDT
Investigating
Customers with Traditional and Hosted VoIP services may be experiencing intermittment service impairment when calling outside DFT's calling area. Network Technicians are aware of the issue and are currently working on a resolution.
Please do not make any changes to your equipment, endpoints, or devices.
An Estimated Time of Restoration (ETR) is not available.
We appreciate your patience.
Posted Sep 05, 2026 - 21:29 EDT
This incident affected: DFT Hosted Voice over IP (VoIP), D&F Telephone Services, and Cassadaga Telephone Services.