Outside Plant Crews are actively assessing and repairing the damage to fiber optic cables and service poles. Due to the extent of the damage, repairs will take longer than anticipated, and an estimated time of restoration (ETR) is not available.
Please do not make any changes to your endpoints or equipment. Updates will be provided when available.
If you have any questions, please contact DFT Support & Repair at 716-673-3031
Posted Apr 15, 2025 - 15:55 EDT
Identified
A fiber break and poles down have been identified within the area of Route 60, which is impacting customers with FTTx service. Crews have been dispatched to the damaged area and are assessing the repairs.
Please do not make any changes to your endpoints or equipment. Updates will be provided when available.
If you have any questions, please contact DFT Support & Repair at 716-673-3031
Posted Apr 15, 2025 - 14:03 EDT
Investigating
Customers with FTTx services in Dunkirk, NY, near Main Street Extension and Vineyard Drive may be experiencing a service interruption. Network and Field Engineers are currently investigating. Please do not make any changes to your equipment or endpoints.
If you have any questions, please contact DFT Support & Repair at 716-673-3031
Posted Apr 15, 2025 - 12:47 EDT
This incident affected: DFT Residential & Business Fiber Service.