Netsync Internet Service Impairment

Incident Report for DFT Communications Network Status

Resolved

All services have been restored by our backbone provider. Network traffic has been restored to normal.

If you need further assistance please contact DFT and Netsync Repair at 716-673-3011.
Posted Mar 03, 2026 - 16:20 EST

Identified

The issue has been identified as an outage within the backbone provider's network, outside DFT/Netsync's immediate control. Network Engineers are actively working with our backbone partner to resolve the issue.

All Netsync routers have automatically rerouted traffic away from this provider until service is restored. Updates will be provided as they become available.

Customers should not make any changes to their equipment or endpoints. Customers experiencing service impairment should contact DFT/Netsync support at 716-673-3011.
Posted Mar 03, 2026 - 12:02 EST

Investigating

Netsync Internet Services is currently experiencing an impairment with one of the backbone providers. Traffic has been rerouted away from this provider until services have been restored. If you are experiencing service issues, please contact DFT Repair at 716-673-3011
Posted Mar 03, 2026 - 11:38 EST
This incident affected: Netsync Internet Services.