Slow/Unresponsive Internet
Incident Report for DFT Communications Network Status
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 15:50 EDT
Monitoring
We are receiving reports of Slow/Unresponsive Internet. Based on reports, the issue appears to be further upstream with Backbone provider peering points and outside DFT & Netsync's Immediate control.

Currently, all systems are functioning normally, but Network Engineers will continue to monitor.

Please do not make any changes to your equipment or endpoints.

If you have any questions please contact DFT's Repair Center at 716-673-3011
Posted Jul 22, 2024 - 15:26 EDT
This incident affected: Netsync Internet Services.