Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2026 - 01:00 EDT
Scheduled
DFT Network Operations will perform routine software updates during the listed hours. During this maintenance, customers will experience service disruptions for the Fiber to the Premise Internet and Voice-connected services. Disruptions are expected to last between 5-15 minutes.
Areas of Impact - Town of Stockton Hall Road Area Laona Area Bard & Griswold Road Areas Village of Fredonia
Please do not make any changes to your equipment or endpoints. If you have any questions please contact DFT Support and Repair at 716-673-3011
Posted Mar 26, 2026 - 01:00 EDT
This scheduled maintenance affected: DFT Residential & Business Fiber Service.