Services have been restored to this area as a result of commercial power outages and brown outs.
Customers may need to power cycle endpoints and routers. If you need assistance or are still experiencing a service interruption, please contact DFT Repair and Support at 716-673-3031
Posted Jul 21, 2026 - 13:28 EDT
Investigating
Network Operations is investigating a service disruption within our East Main Road/Route 20 & Route 60/Fredonia Service area. Technicians have been dispatched to this location.
No Estimated Time of Restoration is currently available. Please do not make changes to your equipment or endpoints. If you have any questions please contact DFT Repair at 716-673-3011
Posted Jul 21, 2026 - 12:48 EDT
This incident affected: DFT Residential & Business Fiber Service and DFT xDSL Residential & Business Internet.