FTTH Impairment Dunkirk Area

Incident Report for DFT Communications Network Status

Resolved

All services have been completely restored. If you still need assistance, please contact DFT Support and Repair at 716-673-3031.
Posted Feb 15, 2025 - 11:03 EST

Update

Most customers within the Dunkirk, NY, Lakefront area have been restored. A few customer services are being restored individually.

If you are still experiencing service impairment, please contact DFT Repair & Support at 716-673-3011.
Posted Feb 14, 2025 - 23:23 EST

Update

Technicians are currently restoring services. We appreciate your patience. ETR is 10:30PM
Posted Feb 14, 2025 - 21:55 EST

Identified

Customers with Fiber to the Home Service near Route 5 and Lakeview Avenue in Dunkirk, NY, may be experiencing a service interruption. Technicians have identified an equipment issue and are working on a resolution.

Please do not make any changes to your equipment or endpoints.
Posted Feb 14, 2025 - 20:37 EST
This incident affected: DFT Residential & Business Fiber Service.