Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 10, 2025 - 01:00 EDT
Scheduled
DFT Network Operations will be performing routine Fiber to the Premise (FTTP) Maintenance during this listed time at locations specified. During this maintenance window, your FTTP service may be briefly interrupted for up to 3 minutes while your Optical Network Terminal (ONT) is rebooted.
Areas where maintenance will be performed-
Village of Fredonia Dunkirk Area Stockton Area Town of Pomfret (West) Hahn Road Area Village of Cassadaga Greenwood/Van Buren Bay Area
Please do not make any changes to your equipment or endpoints.
If you have any questions please contact DFT Support & Repair at 716-673-3031
Posted Apr 02, 2025 - 10:57 EDT
This scheduled maintenance affected: DFT Residential & Business Fiber Service.